assert_db_requirements {admiral}R Documentation

Check required parameters for SMQ/SDG

Description

If SMQs or SDGs are requested, the version and a function to access the database must be provided. The function checks these requirements.

Usage

assert_db_requirements(
  version,
  version_arg_name,
  fun,
  fun_arg_name,
  queries,
  i,
  type
)

Arguments

version

Version provided by user

version_arg_name

Name of the argument providing the version

fun

Function provided by user

fun_arg_name

Name of the argument providing the function

queries

Queries provide by user

i

Index of query being checked

type

Type of query

Should be ⁠"SMQ⁠" or "SDG".

Value

An error is issued if version or fun is null.

Author(s)

Stefan Bundfuss

See Also

Source Specifications: assert_terms(), assert_valid_queries(), censor_source(), date_source(), death_event, derive_var_dthcaus(), event_source(), extend_source_datasets(), filter_date_sources(), format.sdg_select(), format.smq_select(), list_tte_source_objects(), params(), query(), sdg_select(), smq_select(), tte_source(), validate_query(), validate_sdg_select(), validate_smq_select()


[Package admiral version 0.8.4 Index]